File diff 5c57512b04ee → 6d0e5bc50884
setup.py
Show inline comments
 
#!/usr/bin/env python
 

	
 
import os
 
from setuptools import setup, find_packages
 

	
 
import symposion
 

	
 

	
 
def read_file(filename):
 
    """Read a file into a string."""
 
    path = os.path.abspath(os.path.dirname(__file__))
 
    filepath = os.path.join(path, filename)
 
    try:
 
        return open(filepath).read()
 
    except IOError:
 
        return ''
 

	
 

	
 
setup(
 
    name="symposion",
 
    author="James Tauber",
...
 
@@ -12,7 +22,7 @@ setup(
 
    version=symposion.__version__,
 
    description="A collection of Django apps for conference websites.",
 
    url="http://eldarion.com/symposion/",
 
    packages=find_packages(exclude=["symposion_project"]),
 
    packages=find_packages(),
 
    include_package_data=True,
 
    classifiers=(
 
        "Development Status :: 4 - Beta",
...
 
@@ -22,4 +32,5 @@ setup(
 
        "Natural Language :: English",
 
        "License :: OSI Approved :: MIT License",
 
    ),
 
    install_requires=read_file("requirements/base.txt").splitlines(),
 
)