File diff 4cba2b2681ac → 8dbe807efbb1
setup.cfg
Show inline comments
...
 
@@ -12,3 +12,15 @@ warn_redundant_casts = True
 
warn_return_any = True
 
warn_unreachable = True
 
warn_unused_configs = True
 

	
 
[tox:tox]
 
envlist = py36,py37
 

	
 
[testenv]
 
# Beancount includes type declarations but not the `py.typed` flag file mypy
 
# is looking for to know that. Create it ourselves.
 
commands_pre = python -c 'import beancount, pathlib; pathlib.Path(beancount.__file__).with_name("py.typed").touch()'
 

	
 
commands =
 
  ./setup.py test
 
  ./setup.py typecheck